Region Free Trick to Make Some/All Panasonic BD Players Region Free for BD's

digitalbabe

Premium Supporter
Apr 12, 2009
42,349
USA
Hey guys-this is confirmed to work on several Panasonic Blu-Ray players (you need to try your model). It makes the player region free for BD playback.

Thanks Jung @ TBS-

All you need to do is load up the disc. When the message pops up that says the disc will only play in a Region B or C player pops up, press "stop" on the remote control. Then press "1" on the remote, followed by "enter." This will bypass the message and load up the disc to play normally.

 

digitalbabe

Premium Supporter
Apr 12, 2009
42,349
USA
Thanks for the tip. Should this work on a Region B player? I can't access mine until tomorrow evening.
Hey X-I don't know-the info posted elsewhere indicated it needed to be tried out to see if it works. I tried it on US BD35 and it worked fine. Hope this helps more people, especially with level of importing occurring all over. Good luck, guys!
 

Buffalo MX

@MrSteel_MEX
BANNED
Premium Supporter
Jul 20, 2010
3,951
México
Hey X-I don't know-the info posted elsewhere indicated it needed to be tried out to see if it works. I tried it on US BD35 and it worked fine. Hope this helps more people, especially with level of importing occurring all over. Good luck, guys!
I have a USA BD35 here at the office

I did stop -> 1 -> ok (did not find a ENTER button) did not work

Used Leon and Reservoir Dogs German discs

This is my remote

http://myhdtvchoice.com/wp-content/uploads/2008/10/panasonic-dmp-bd35-remote.png
 

cooey

Super Moderator
Premium Supporter
I have a USA BD35 here at the office

I did stop -> 1 -> ok (did not find a ENTER button) did not work

Used Leon and Reservoir Dogs German discs

This is my remote

http://myhdtvchoice.com/wp-content/uploads/2008/10/panasonic-dmp-bd35-remote.png
I've got the same remote with my BD-30, didn't work :(

Not that it really matters as I've got a UK PS3, but it would've been awesome if it did :)
 

cooey

Super Moderator
Premium Supporter
Hey DB

Yeah tried on both my harmony remote and actual player remote. All it said on the screen was 'that option is disabled' every time I pressed a button and nothing happened
 

digitalbabe

Premium Supporter
Apr 12, 2009
42,349
USA
Hey Cooey, that happened to me if I pressed the buttons to slow. Try hitting the button sequence faster, it worked for me then, the 2nd time. Good luck!